Expense OCR Issues
Incident Report for TravelBank
Postmortem

This issue occurred due to changes related to how we are storing expense receipt images. The changes were tied to our 8.13.0 API release which was initially released on April 18th. The changes resulted in requests to our OCR provider being made before the receipts had completed uploading, resulting in OCR not functioning properly. Our regression testing in our preproduction environments did not catch this issue, but we are updating our automation tests to ensure that this issue will not occur again with future releases. With all releases, we do our best to identify and resolve any issues before we release, but from time to time issues will make it past our testing either due to variation between our production and preproduction environments or testing gaps. We use every incident/issue as learning opportunity to continuously improve. We apologize for the inconvenience this issue posed to some of our customers and will do our best to ensure it does not happen again.

Posted Apr 23, 2024 - 15:04 PDT

Resolved
This issue has been resolved.
Posted Apr 22, 2024 - 10:30 PDT
Identified
There is an issue at the moment related to expense OCR. Expense receipt attachments are not automatically being scanned. We are working on a fix for this and will provide an update as soon as it is released.
Posted Apr 19, 2024 - 14:33 PDT
This incident affected: Expenses (Expense Receipts).