Plaid Chase
Incident Report for TravelBank
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 07:57 PST
Investigating
There is an issue with corporate card feeds related Chase Business and Consumer cards. We are aware of the issue and investigating. The impacted feeds have been temporarily disabled while we investigate.
Posted Dec 14, 2023 - 10:06 PST