TravelBank hotel post-pay inventory unavailable

Incident Report for TravelBank

Resolved

This incident has been resolved. Pay at hotel inventory is now available in the app.
Posted Nov 26, 2025 - 18:27 PST

Update

We will provide an update as soon as possible.
Posted Nov 26, 2025 - 15:08 PST

Identified

TravelBank’s post-pay hotel inventory is temporarily inaccessible due to a provider issue. Our provider is working to resolve this as quickly as possible. Apologies for any inconvenience in the meantime.
Posted Nov 26, 2025 - 15:08 PST
This incident affected: Hotels (Book, Search).