Continued mainteance
Incident Report for TravelBank
Resolved
Maintenance is complete!
Posted 4 months ago. May 26, 2019 - 03:45 PDT
Identified
Our servers are still being worked on at this time, thank you!
Posted 4 months ago. May 26, 2019 - 00:11 PDT
This incident affected: API, Reimbursements, OCR, Website, Hotels (Book, Search), Flights (Search, Book), Expenses (Credit Card Sync, Email Forwarding), and Notifications (Email delivery, Push delivery).