System Outage
Incident Report for TravelBank
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 24, 2019 - 18:10 PDT
Investigating
We are currently experiencing a system wide outage and are investigating.
Posted 3 months ago. Jun 24, 2019 - 18:00 PDT
This incident affected: API, Reimbursements, OCR, Hotels (Book, Search), Flights (Search, Book), Expenses (Credit Card Sync, Email Forwarding), and Notifications (Email delivery, Push delivery).