Email Notification Delivery
Incident Report for TravelBank
Resolved
The issue has been resolved
Posted over 1 year ago. Apr 18, 2018 - 17:05 PDT
Monitoring
Email delivery should be restored. We will continue to montior.
Posted over 1 year ago. Apr 18, 2018 - 13:02 PDT
Identified
We've identified the issue and are deploying a fix.
Posted over 1 year ago. Apr 18, 2018 - 12:58 PDT
Investigating
Customers are reporting missing email notifications. We are investigating
Posted over 1 year ago. Apr 18, 2018 - 10:53 PDT