Flight Search Outage
Incident Report for TravelBank
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 11, 2019 - 11:42 PDT
Investigating
We are currently experiencing an outage with our flight search service. We are investigating
Posted 3 months ago. Jun 11, 2019 - 11:08 PDT
This incident affected: Flights (Search).