Flight Bookings
Incident Report for TravelBank
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 10, 2019 - 11:32 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jun 10, 2019 - 11:31 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jun 10, 2019 - 10:59 PDT
Investigating
We are experiencing some booking failures with our upstream flights' provider. We are working with them to resolve it as soon as possible. Please try again later or contact an agent if you need to book immediately
Posted 3 months ago. Jun 10, 2019 - 09:27 PDT
This incident affected: Flights (Book).