Flight Email Issue

Incident Report for TravelBank

Resolved

The fix for flight emails has been released and the flight details are now appearing in full. Please contact support if you have any further issues.
Posted Feb 26, 2025 - 18:12 PST

Update

A fix is created for flight emails not displaying all the flight information and will be released after business hours tonight (2/26/25).
Posted Feb 26, 2025 - 08:03 PST

Identified

We're currently experiencing a temporary issue with flight confirmation emails not being populated correctly and missing certain fields.

We apologize for the inconvenience and are working to resolve this as soon as possible. In the meantime you can check the trip details in app to get the full flight information. If you need further assistance, please reach out to our support teams.
Posted Feb 26, 2025 - 07:38 PST
This incident affected: Flights (Book).