After monitoring the Expense Report loading issue since releasing the fix last night we have confirmed there have not been any further instances of the issue. Please reach out to our customer support if you are experiencing any issues.
Posted Oct 01, 2025 - 08:56 PDT
Monitoring
The fix for the issue has been released. We will continue to monitor to ensure it is working as expected. Please reach out to our customer support if you have any further issues.
Posted Sep 30, 2025 - 16:13 PDT
Identified
There is currently an issue causing the expense report approvals page to fail to load for some users. It appears to impact organizations with large numbers of custom field categories more frequently. We have identified the underlying issue and are validating a fix. The patch will be released this evening and the status will be updated accordingly.
Posted Sep 30, 2025 - 16:09 PDT
This incident affected: Expenses (Expense Reports).