Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 23:14 PDT
Update
We are continuing to investigate this issue.
Posted May 11, 2026 - 23:13 PDT
Update
We are continuing to investigate this issue.
Posted May 11, 2026 - 20:03 PDT
Update
We are continuing to investigate this issue.
Posted May 11, 2026 - 19:58 PDT
Investigating
We are currently investigating an issue
Posted May 11, 2026 - 19:15 PDT
This incident affects: Notifications (Email delivery, Push delivery), Flights (Search, Book, Analytics), Expenses (Credit Card Sync, Email Forwarding, Expense Reports, Expense Receipts), Hotels (Book, Search, Analytics), Core (Login, API, Premium Insights), Cars (Car Search, Car Booking), Integrations - General Ledger (Quickbooks Online, Netsuite, Xero), and Reimbursements, OCR, Website, Rewards, Commercial Rewards.