Expense and Transaction Unauthorized error

Incident Report for TravelBank

Resolved

This incident has been resolved.
Posted May 26, 2025 - 06:55 PDT

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 10:45 PDT

Monitoring

We have applied a fix for the issue. We are monitoring to ensure functionality is restored
Posted May 23, 2025 - 10:36 PDT

Investigating

We are currently investigating a partial outage of the expense and transactions page. Some users are experiencing an unauthorized error when attempting to access the page.
Posted May 23, 2025 - 10:35 PDT
This incident affected: Expenses (Credit Card Sync, Email Forwarding, Expense Reports, Expense Receipts).