iOS Booking Issues
Incident Report for TravelBank
Resolved
This issue has been resolved with the latest iOS update.
Posted Nov 14, 2023 - 12:30 PST
Identified
We are currently facing issues booking travel on the iOS app. The issue has been identified and we are working to resolve the issue as soon as possible.
Posted Nov 01, 2023 - 08:59 PDT
This incident affected: Flights (Book).