Commercial Rewards Card Cardholders Cannot View Their Statements
Incident Report for TravelBank
Resolved
The incident has been resolved. Cardholders can now view their statements.
Posted Dec 05, 2023 - 09:40 PST
Identified
Commercial Rewards Card cardholders cannot view their statements.

Until resolved: Only admins have access to statements. To obtain cardholder statements admins should navigate to the Manage Tab > Statements > Cardholder Accounts > choose the cardholder > click "View all" > option to view or download available statements.
Posted Nov 21, 2023 - 12:07 PST
This incident affected: Commercial Rewards.