Card Management Outage

Incident Report for TravelBank

Resolved

The card management issue has been resolved. Thank you for your patience and understanding. Please reach out via chat for any additional support.
Posted Jul 29, 2025 - 10:59 PDT

Investigating

Card management is currently experiencing an outage. The outage includes the ability to make a payment, view a statement, create a card, view card details, etc. Please reach out via chat for additional support.
Posted Jul 29, 2025 - 10:32 PDT