Inventory Issue

Incident Report for TravelBank

Resolved

Our provider has resolved their flight booking issue. Please reach out to support or chat with us if you face any further issues.
Posted May 01, 2025 - 17:48 PDT

Identified

We’re currently facing issues with United and American Airlines inventory within the app due to an outage with our third-party flight provider. Please reach out to support or chat with us to assist with your bookings while we await resolution. Apologies for the inconvenience!
Posted May 01, 2025 - 15:50 PDT
This incident affected: Flights (Book).