Delayed Reimbursements
Incident Report for TravelBank
Resolved
All reimbursements have confirmed processed.
Posted Mar 15, 2024 - 14:03 PDT
Monitoring
Reimbursements for Friday, March 15th may be delayed a few hours, but they should still be processed by the end of the day.
Posted Mar 15, 2024 - 10:08 PDT
This incident affected: Reimbursements.