Elevated Booking Errors
Incident Report for TravelBank
Resolved
The travel team was able to confirm that booking error rates are within normal range.
Posted Dec 01, 2023 - 15:13 PST
Investigating
There are reports of increased errors when booking travel. We are investigating.
Posted Dec 01, 2023 - 12:25 PST
This incident affected: Hotels (Book) and Flights (Book).