Premium Insights Reports Not Loading
Incident Report for TravelBank
Resolved
This has now been resolved.
Posted Feb 29, 2024 - 16:05 PST
Identified
Premium Insights reports are not currently loading. We are working on a resolution
Posted Feb 29, 2024 - 16:00 PST
This incident affected: Core (Premium Insights).