Seat Selection
Incident Report for TravelBank
Resolved
The issue has been resolved
Posted 10 months ago. Jul 24, 2018 - 14:56 PDT
Investigating
We're currently investigating an issue with in-app seat selection.
Posted 10 months ago. Jul 19, 2018 - 11:07 PDT
This incident affected: Flights (Book).