Amazon Rewards Not Redeemable
Incident Report for TravelBank
Resolved
All reward redemption should be good to go.
Posted 11 months ago. Sep 28, 2018 - 13:09 PDT
Identified
We are currently experiencing an issue with redeeming Amazon Rewards, we anticipate that it should be back up within a few days.
Posted 11 months ago. Sep 27, 2018 - 22:12 PDT