2024 Mileage Rates Not Available
Incident Report for TravelBank
Resolved
This incident has been resolved. 2024 IRS mileage rates should be added.
Posted Jan 02, 2024 - 16:15 PST
Investigating
There is an issue with 2024 mileage rates not populating correctly for mileage expenses. We are investigating.
Posted Jan 02, 2024 - 09:58 PST