Travel Booking Maintenance Window Jan 14th

Incident Report for TravelBank

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 05:04 PST

Monitoring

There is no ongoing incident, however our travel providers are performing a system upgrade on January 14th at 10:30 AM PST to 2:30 PM PST. This may result in service interruptions with bookings. Please reach out to our travel support team if you encounter any issues.
Posted Jan 13, 2026 - 08:07 PST
This incident affected: Hotels (Book), Flights (Book), and Cars (Car Booking).