Email Notification Delivery
Incident Report for TravelBank
Resolved
The issue has been resolved
Posted over 1 year ago. Jun 21, 2018 - 15:24 PDT
Monitoring
Email delivery should be restored. We will continue to monitor.
Posted over 1 year ago. Jun 21, 2018 - 12:31 PDT
Identified
We've identified the issue and are deploying a fix.
Posted over 1 year ago. Jun 21, 2018 - 10:25 PDT
Investigating
Customers are reporting missing email notifications. We are investigating
Posted over 1 year ago. Jun 21, 2018 - 09:17 PDT
This incident affected: Notifications (Email delivery).