Hotel and Car Search Outage

Incident Report for TravelBank

Resolved

We have monitored the fix for a few hours and haven't seen further issues. This incident has been resolved.
Posted Jun 25, 2025 - 12:20 PDT

Monitoring

A fix has been made and validated. Please reach out to our support team if you have any further issues.
Posted Jun 25, 2025 - 09:08 PDT

Identified

We have identified an issue with Car and Hotel search and are actively working on a solution.
Posted Jun 25, 2025 - 08:58 PDT
This incident affected: Cars (Car Search) and Hotels (Search).