Car Booking Confirmation Email Issue

Incident Report for TravelBank

Resolved

A fix has been implemented and car booking confirmation emails are now sending as expected.
Posted Jul 24, 2025 - 17:21 PDT

Identified

The root issue causing the car confirmation emails to not be sent has been identified. A fix has been created and is currently scheduled for release tomorrow evening.
Posted Jul 23, 2025 - 14:03 PDT

Investigating

Car booking confirmation emails are currently not being sent. Your booking is still successful, and all details can be found in the app under My Trips.
If you need help verifying your booking or have any questions, please reach out to support or chat with us while we're working to restore the confirmation emails. Apologies for the inconvenience!
Posted Jul 23, 2025 - 08:17 PDT
This incident affected: Notifications (Email delivery).