Core & Premium Insights Outage
Incident Report for TravelBank
Resolved
This incident has been resolved. Both Core and Premium Insights are operational.
Posted Nov 25, 2024 - 14:37 PST
Investigating
We are currently experiencing an issue with reporting for Core and Premium Insights. We are working on a resolution and will have your data available as soon as possible.
Posted Nov 25, 2024 - 12:22 PST
This incident affected: Core (Premium Insights).