Network Issues Accessing TravelBank from Mobile
Incident Report for TravelBank
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 08:55 PDT
Monitoring
A change that was made in our network is causing our mobile apps to have network connectivity. This has been reverted and mobile apps should be working as expected once again.
Posted Mar 17, 2024 - 09:14 PDT
Investigating
We are investigating network issues experienced while using the mobile application. The web application is working as expected.
Posted Mar 17, 2024 - 08:52 PDT